HDU 2817 A sequence of numbers 等比OR等次

HDU 2817 A sequence of numbers 等比OR等差

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3796    Accepted Submission(s): 1164


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
 
看了样例,YY一下,感觉要么等差要么等比,然后一写一交就过啦,(*^__^*) 嘻嘻……

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define mod 200907
#define ll __int64
#define N 100
using namespace std;

ll fun(ll m,ll n)
{
    ll b=1;
    while(n)
    {
        if(n&1)
        b=(b*m)%mod;
       n=n>>1;
        m=(m*m)%mod;
    }
    return b;
}

int main()
{
    ll T;
    ll a,b,c,k;
    while(~scanf("%I64d",&T))
    {
        while(T--)
        {
            scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k);

            ll d;
            ll ans;
            if(b-a==c-b)
            {
                d=b-a;
                ans=(d*k-d+a)%mod;
            }

            else if(b/a==c/b)
            {
                d=b/a;
                ans=(a*fun(d,k-1))%mod;
            }
             printf("%I64d\n",ans);

        }
    }
    return 0;
}