HDU 2187 A sequence of numbers【高速幂】

HDU 2187 A sequence of numbers【快速幂】


快速幂的求法之总结


题意不是等差就是等比数列

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3983    Accepted Submission(s): 1219


Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
2 1 2 3 5 1 2 4 5
 

Sample Output
5 16
 

Source
2009 Multi-University Training Contest 1 - Host by TJU


#include<stdio.h>
#include<math.h>
#define ll __int64
#define mod 200907
#define N 100

ll fun(ll a,ll b)
{
	ll s=1;
	
	a=a%mod;
	
	while(b>0)
	{
		if(b%2==1)//判断一下b是否为奇数
			s=(s*a)%mod;//如果是奇数,则多乘一项 
		b=b/2;
		a=(a*a)%mod; 
	}
	return s;
}

int main()
{
	int s;
	ll a,b,c,k;
	scanf("%d",&s);
	while(s--)
	{
		scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
		ll d;
		ll ans;
		if(c-b==b-a)
		{
			d=b-a;
			ans=(a+(k-1)*d)%mod;
		}
		
		else if(b/a==c/b)
		{
			d=b/a;
			ans=(a*fun(d,k-1))%mod;
		}
		printf("%I64d\n",ans);
	}
	
	return 0;
}