HDU1003 Max Sum(求最大字段跟)

HDU1003 Max Sum(求最大字段和)

其实这连续发表的三篇是一模一样的思路,我就厚颜无耻的再发一篇吧!

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6


代码如下:

#include <cstdio>
#define INF 0x3fffffff
#define M 100000+17
int a[M];
int main()
{
	int n, i, T, k = 0;
	while(~scanf("%d",&T))
	{
		while(T--)
		{
			scanf("%d",&n);
			int s = 1, e = 1, t = 1;
			int sum = 0, MAX = -INF;
			for(i = 1; i <= n; i++)
			{
				scanf("%d",&a[i]);
				sum+=a[i];
				if(sum > MAX)
				{
					s = t;
					e = i;
					MAX = sum;
				}
				if(sum < 0)
				{
					t = i+1;
					sum = 0;
				}
			}
			printf("Case %d:\n",++k);
			printf("%d %d %d\n",MAX,s,e);
			if(T!=0)
				printf("\n");
		}
	}
	return 0;
}