[ACM] hdu 1003 Max Sum(最大子段跟模型)

[ACM] hdu 1003 Max Sum(最大子段和模型)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 135262    Accepted Submission(s): 31311


Problem Description

 

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 


 

Input

 

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 


 

Output

 

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 


 

Sample Input

 

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 


 

Sample Output

 

Case 1: 14 1 4 Case 2: 7 1 6
 


 

Author

 

Ignatius.L

 

解题思路:

当所有数都为负数时,最大子段和为0.

int MaxSum(int num[],int n)
{
    int sum=0,b=0;
    int i;
    for (i=1;i<=n;i++)
    {
        if(b>0)
            b+=num[i];
        else
            b=num[i];
        if(b>sum)
            sum=b;
    }
    return sum;
}

只求最大和,没有保存位置。

保存位置:start为起 end为末

       int start=1,end=1,s=1,e=1;
       int sum=0,max=num[0];//不能让max=0
        for(int i=1;i<=n;i++)
        {
            e=i;
            sum=sum+num[i];
            if(max<sum)
            {
                max=sum;
                start=s;
                end=e;
            }
            if(sum<0)
            {
                s=i+1;
                sum=0;
            }
        }


 

本题需要保存起始位置。

代码:

#include <iostream>
using namespace std;
const int maxn=100002;
int num[maxn];
int n;
int main()
{
    int t;cin>>t;int c=1;
    while(t--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>num[i];
        int start=1,end=1,s=1,e=1;
        int sum=0,max=num[0];//不能让max=0
        for(int i=1;i<=n;i++)
        {
            e=i;
            sum=sum+num[i];
            if(max<sum)
            {
                max=sum;
                start=s;
                end=e;
            }
            if(sum<0)
            {
                s=i+1;
                sum=0;
            }
        }
        cout<<"Case "<<c++<<":"<<endl;
        cout<<max<<" "<<start<<" "<<end<<endl;
        if(t)
            cout<<endl;
    }
    return 0;
}