HDU2614Beat(DP状态压缩途径)

HDU2614Beat(DP状态压缩路径)

Beat

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 669    Accepted Submission(s): 424


Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 

Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 

Output
For each test case output the maximum number of problem zty can solved.


 

Sample Input
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output
3 2 4
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
 
#include<stdio.h>

const int N = 1<<14;
const int inf = 0xffffff;

int k[N];
void init()
{
    for(int i=1;i<N; i++)
    {
        int n=0;
        for(int s=0;(1<<s)<=i; s++)
            if((1<<s)&i)
            n++;
        k[i]=n;
    }
}
int main()
{
    int n,map[14][14],dp[N][14],maxlen;
    init();
    while(scanf("%d",&n)>0)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            scanf("%d",&map[i][j]);
        for(int s=1;s<(1<<n);s++)
        for(int i=0;i<n;i++)
            dp[s][i]=inf;

        dp[1<<0][0]=0;
        maxlen=0;

        for(int s=1; s<(1<<n); s++)
        for(int i=0; (1<<i)<=s; i++)
        if(dp[s][i]!=inf)
        {
            if(maxlen<k[s])maxlen=k[s];
            for(int j=0;j<n;j++)
                if(!((1<<j)&s)&&map[i][j]>=dp[s][i]&&dp[s|(1<<j)][j]>map[i][j])
                    dp[s|(1<<j)][j]=map[i][j];
        }
        printf("%d\n",maxlen);
    }
}