HDOJ 标题1423 Greatest Common Increasing Subsequence(LICS)

HDOJ 题目1423 Greatest Common Increasing Subsequence(LICS)

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4693    Accepted Submission(s): 1496


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
2
 

Source
ACM暑期集训队练习赛(二)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1422 1400 1424 1401 1404 
 
ac代码
#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int a[550],b[550],n,m,dp[550];
int lics()
{
    int ans=0,i,j;
    for(i=1;i<=n;i++)
    {
        int ma=0;
        for(j=1;j<=m;j++)
        {
            int temp=ma;
            if(b[j]<a[i]&&dp[j]>ma)
                ma=dp[j];
            if(b[j]==a[i])
                dp[j]=temp+1;
            ans=max(ans,dp[j]);
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        //int n,m;
        int i,j;
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(j=1;j<=m;j++)
            scanf("%d",&b[j]);
        printf("%d\n",lics());
        if(t)
            printf("\n");
    }
}