hdu 1385 Minimum Transport Cost(最短路 + 字典序最小途径)

hdu 1385 Minimum Transport Cost(最短路 + 字典序最小路径)

hdu 1385 Minimum Transport Cost

Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 … a1N
a21 a22 … a2N
……………
aN1 aN2 … aNN
b1 b2 … bN

c d
e f

g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, …, and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :
Path: c–>c1–>……–>ck–>d
Total cost : ……
……

From e to f :
Path: e–>e1–>……….–>ek–>f
Total cost : ……

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1–>5–>4–>3
Total cost : 21

From 3 to 5 :
Path: 3–>4–>5
Total cost : 16

From 2 to 4 :
Path: 2–>1–>5–>4
Total cost : 17

题目大意:给出一张图,在求出最短路的前提下,输出最小字典序。

解题思路:点不多,可以用floyd。要在原先的基础上判断Gra[i][j]==Gra[i][k]+Gra[k][j]+Cos[k]的情况,当满足上述条件,在判断path[i][j]path[i][k]的关系,path[i][j] > path[i][k]时,使,path[i][j] = path[i][k]。这样可以保证字典序。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
const int N = 105;
const int INF = 0x3f3f3f3f;
int n, Gra[N][N], path[N][N], Cos[N];

void input() {
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            scanf("%d", &Gra[i][j]);    
            if (Gra[i][j] == -1) Gra[i][j] = INF;
        }   
    }   
    for (int i = 1; i <= n; i++) {
        scanf("%d", &Cos[i]);   
    }
}

void floyd() {
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            path[i][j] = j; 
        }   
    }
    for (int k = 1; k <= n; k++) {
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= n; j++) {
                int temp = Gra[i][k] + Gra[k][j] + Cos[k];
                if (Gra[i][j] > temp) { //保证最短路
                    Gra[i][j] = temp;
                    path[i][j] = path[i][k];    
                } else if (Gra[i][j] == temp) { //保证在最短路的前提下,字典序最小
                    if (path[i][j] > path[i][k]) {
                        path[i][j] = path[i][k];    
                    }   
                }
            }   
        }   
    }
}

void printfPath(int s, int t) {
    int move = s;
    printf("Path: %d", s);
    while (move != t) {
        printf("-->%d", path[move][t]); 
        move = path[move][t];
    }
    puts("");
}

int main() {
    int a, b;
    while (scanf("%d", &n) != EOF, n) {
        input();
        floyd();
        while (scanf("%d %d", &a, &b) == 2)  {
            if (a == -1 && b == -1) break;
            if (a == b) {
                printf("From %d to %d :\n", a, b);  
                printf("Path: %d\n", a);
                printf("Total cost : 0\n\n");
                continue;
            }
            printf("From %d to %d :\n", a, b);
            printfPath(a, b);
            printf("Total cost : %d\n\n", Gra[a][b]);
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。