九度OJ 题目1039:Zero-complexity Transposition
题目1039:Zero-complexity Transposition
时间限制:1 秒
内存限制:32 兆
特殊判题:否
提交:1508
解决:570
-
题目描述:
-
You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.
-
输入:
-
For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).
-
输出:
-
For each case, on the first line of the output file print the sequence in the reverse order.
-
样例输入:
-
5
-3 4 6 -8 9
-
样例输出:
-
9 -8 6 4 -3
-
来源:
- 2007年上海交通大学计算机研究生机试真题
-
/*********************************
* 日期:2013-2-19
* 作者:SJF0115
* 题号: 九度OJ 题目1039:Zero-complexity Transposition
* 来源:http://ac.jobdu.com/problem.php?pid=1039
* 结果:AC
* 来源:2007年上海交通大学计算机研究生机试真题
* 总结:
**********************************/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
int i,n;
while(scanf("%d",&n) != EOF){
long long int a[n];
for(i = 0;i < n;i++)
{
scanf("%lld",&a[i]);
}
for(i = n - 1;i >= 0;i--)
{
printf("%lld",a[i]);
if(i == 0)
{
printf("\n");
}
else{
printf(" ");
}
}
}
return 0;
}
第二种方法:字符串
/*********************************
* 日期:2013-2-19
* 作者:SJF0115
* 题号: 九度OJ 题目1039:Zero-complexity Transposition
* 来源:http://ac.jobdu.com/problem.php?pid=1039
* 结果:AC
* 来源:2007年上海交通大学计算机研究生机试真题
* 总结:
**********************************/
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
string Num[10000];
int N,i;
while (cin>>N)
{
for (i=0;i<N;i++)
{
cin>>Num[i];
}
for (i=N-1;i>0;i--)
{
cout<<Num[i]<<" ";
}
cout<<Num[0]<<endl;
}
return 0;
}