POJ-2828(线段树)
Time Limit: 4000MS | Memory Limit: 65536KB | 64bit IO Format: %I64d & %I64u |
Description
Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…
The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.
It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!
People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.
Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:
- Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
- Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.
Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.
Sample Input
4 0 77 1 51 1 33 2 69 4 0 20523 1 19243 1 3890 0 31492
Sample Output
77 33 69 51 31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.
逆推,转化很重要,输入的最后一个此位置的人肯定就是在这个位置了,如果一个人的位置在pos那么说明它前面一定有pos个位置,如果是逆着来推的话,肯定前面必然还有pos个空位置的可以安放的位置才是正确的位置,用线段树来记录每个区间里共有多少个空位置,每次进行查询的时候根节点都要-1进行更新,其实query里的最后的pushup可以省略,因为每次向下查询的时候res都更新了,一开始pushup的位置搞错了wa,其实还是因为理解不够透彻。
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxd=200000+5;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
typedef long long ll;
typedef pair<int,int> pii;
//---------------------------
int n,res[maxd<<2],p[maxd],v[maxd],ans[maxd];
void pushup(int rt)
{
res[rt]=res[rt<<1]+res[rt<<1|1];
}
void build(int l,int r,int rt)
{
if(l==r)
{
res[rt]=1;
return;
}
int m=(l+r) >> 1;
build(lson);
build(rson);
pushup(rt);
}
void query(int pos,int val,int l,int r,int rt)
{
res[rt]--;
if(l==r)
{
ans[l]=val;
// pushup(rt);
return;
}
int m=(l+r)>>1;
if(pos<=res[rt<<1]) query(pos,val,lson);
else query(pos-res[rt<<1],val,rson);
pushup(rt);
}
int main()
{
//freopen("1.txt","r",stdin);
while(scanf("%d",&n)!=EOF)
{
build(1,n,1);
for(int i=0; i<n; ++i)
scanf("%d%d",&p[i],&v[i]);
for(int i=n-1; i>=0; --i)
query(p[i]+1,v[i],1,n,1);
for(int i=1; i<=n; ++i)
printf("%d%c",ans[i],i<n?' ':'\n');
}
return 0;
}
逆推,转化很重要,输入的最后一个此位置的人肯定就是在这个位置了,如果一个人的位置在pos那么说明它前面一定有pos个位置,如果是逆着来推的话,肯定前面必然还有pos个空位置的可以安放的位置才是正确的位置,用线段树来记录每个区间里共有多少个空位置,每次进行查询的时候根节点都要-1进行更新,其实query里的最后的pushup可以省略,因为每次向下查询的时候res都更新了,一开始pushup的位置搞错了wa,其实还是因为理解不够透彻。
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxd=200000+5;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
typedef long long ll;
typedef pair<int,int> pii;
//---------------------------
int n,res[maxd<<2],p[maxd],v[maxd],ans[maxd];
void pushup(int rt)
{
res[rt]=res[rt<<1]+res[rt<<1|1];
}
void build(int l,int r,int rt)
{
if(l==r)
{
res[rt]=1;
return;
}
int m=(l+r) >> 1;
build(lson);
build(rson);
pushup(rt);
}
void query(int pos,int val,int l,int r,int rt)
{
res[rt]--;
if(l==r)
{
ans[l]=val;
// pushup(rt);
return;
}
int m=(l+r)>>1;
if(pos<=res[rt<<1]) query(pos,val,lson);
else query(pos-res[rt<<1],val,rson);
pushup(rt);
}
int main()
{
//freopen("1.txt","r",stdin);
while(scanf("%d",&n)!=EOF)
{
build(1,n,1);
for(int i=0; i<n; ++i)
scanf("%d%d",&p[i],&v[i]);
for(int i=n-1; i>=0; --i)
query(p[i]+1,v[i],1,n,1);
for(int i=1; i<=n; ++i)
printf("%d%c",ans[i],i<n?' ':'\n');
}
return 0;
}
#include<cstdio> #include<cstdlib> #include<cstring> #include<iostream> #include<algorithm> #include<string> #include<cmath> #include<queue> #include<vector> #include<map> #include<set> #define INF 0x3f3f3f3f #define mem(a,b) memset(a,b,sizeof(a)) using namespace std; const int maxd=200000+5; #define lson l,m,rt<<1 #define rson m+1,r,rt<<1 | 1 typedef long long ll; typedef pair<int,int> pii; //--------------------------- int n,res[maxd<<2],p[maxd],v[maxd],ans[maxd]; void pushup(int rt) { res[rt]=res[rt<<1]+res[rt<<1|1]; } void build(int l,int r,int rt) { if(l==r) { res[rt]=1; return; } int m=(l+r) >> 1; build(lson); build(rson); pushup(rt); } void query(int pos,int val,int l,int r,int rt) { res[rt]--; if(l==r) { ans[l]=val; // pushup(rt); return; } int m=(l+r)>>1; if(pos<=res[rt<<1]) query(pos,val,lson); else query(pos-res[rt<<1],val,rson); pushup(rt); } int main() { //freopen("1.txt","r",stdin); while(scanf("%d",&n)!=EOF) { build(1,n,1); for(int i=0; i<n; ++i) scanf("%d%d",&p[i],&v[i]); for(int i=n-1; i>=0; --i) query(p[i]+1,v[i],1,n,1); for(int i=1; i<=n; ++i) printf("%d%c",ans[i],i<n?' ':'\n'); } return 0; }