POJ1328 区间选点有关问题(贪心)

POJ1328 区间选点问题(贪心)

以下内容复制于http://blog.****.net/dgq8211/article/details/7534776


先来看看什么是区间选点问题



数轴上有n个闭区间[ai,bi]。取尽量少的点,使得每个区间内都至少有一个点(不同区间内含的点可以是同一个)。

贪心策略:

按照b1<=b2<=b3…(b相同时按a从大到小)的方式排序排序,从前向后遍历,当遇到没有加入集合的区间时,选取这个区间的右端点b。

证明:

为了方便起见,如果区间i内已经有一个点被取到,我们称区间i被满足。

1、首先考虑区间包含的情况,当小区间被满足时大区间一定被满足。所以我们应当优先选取小区间中的点,从而使大区间不用考虑。

      按照上面的方式排序后,如果出现区间包含的情况,小区间一定在大区间前面。所以此情况下我们会优先选择小区间。

      则此情况下,贪心策略是正确的。

2、排除情况1后,一定有a1<=a2<=a3……。

POJ1328 区间选点有关问题(贪心)

      对于区间1来说,显然选择它的右端点是明智的。因为它比前面的点能覆盖更大的范围。

      从而此情况下,贪心策略也是正确的。


#include <stdio.h>
#include <algorithm>
using namespace std;
struct Extent
{
    int a,b;
    bool operator < (const Extent& S)const
    {
        return b < S.b || b == S.b && a > S.a;
    }
}A[10002];
int main()
{
    int z,n,cnt,end;
    scanf("%d",&z);
    while(z--)
    {
        cnt = 0;
        end = -1;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d",&A[i].a,&A[i].b);
        sort(A,A+n);
        for(int i=0;i<n;i++)
        {
            if(end < A[i].a)
            {
                end = A[i].b;
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
	return 0;
}


例题:http://acm.nyist.net/JudgeOnline/problem.php?pid=287

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38208   Accepted: 8483

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
POJ1328 区间选点有关问题(贪心)
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002

题目的意思就是给你一个坐标轴,雷达在x轴上,岛屿分布在x轴上方,给你岛屿的坐标以及雷达的最大扫描面积,求最少用几个雷达可以将所有的岛屿覆盖!


思路:

以岛为圆心,以d为半径画圆(d是雷达的辐射半径),其与x轴相交的区间为一个区  这样就变成了在区间内找最少的点问题了


#include<iostream>
#include<cmath>
using namespace std;
typedef struct
{
	double l,r;
}in;
int cmp(const void *a, const void *b)
{
	return (*(in *)a).l >= (*(in *)b).l ? 1:-1;
}
int main()
{
	int n,d,i,x,y,sw,re,count = 1;
	double pre;
	in p[1000];
	while(1)
	{
		cin>>n>>d;
		if(n == 0 && d==0) break;
		sw = 1;
		for(i=0;i<n;i++)
		{
			cin>>x>>y;
			if(d>=y&&sw==1)
			{
				p[i].l = x-sqrt((double)d*d - (double)y*y);
				p[i].r = x+sqrt((double)d*d - (double)y*y);
			}
			else
			{
				sw = 0;
			}
		}
		if(sw == 0)
		{
			cout<<"Case "<<count++<<": "<<-1<<endl;
			continue;
		}
		qsort(p,n,sizeof(in),cmp); 
		re = 1;
		pre = p[0].r;
		for(i=1;i<n;i++)
		{
			if(p[i].l>pre)
			{
				re++;
				pre = p[i].r;
			}
			else
			{
				if(p[i].r<pre)
				{
					pre = p[i].r;
				}
			}
		}
		cout<<"Case "<<count++<<": "<<re<<endl;
	}
	return 0;
}