2019春第十二周作业
6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n
个字符串存储在s[]
中,函数max_len
应返回其中最长字符串的长度。
裁判测试程序样例
#include <stdio.h> #include <string.h> #include <stdlib.h> #define MAXN 10 #define MAXS 20 int max_len( char *s[], int n ); int main() { int i, n; char *string[MAXN] = {NULL}; scanf("%d", &n); for(i = 0; i < n; i++) { string[i] = (char *)malloc(sizeof(char)*MAXS); scanf("%s", string[i]); } printf("%d ", max_len(string, n)); return 0; } /* 你的代码将被嵌在这里 */
输入样例:
4 blue yellow red green
输出样例:
6
实验代码:
int max_len( char *s[], int n ) { int m=0; for(int i=0;i<n;i++) { int t=strlen(s[i]); if(m < t) { m=t; } } return m; }
设计思路:
遇到的问题及其解决方法:
无疑惑
运行结果截图:
6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head
是用户传入的学生学号链表的头指针;函数countcs
统计并返回head
链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d ", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202 2022310 8102134 1030912 3110203 4021205 #
输出样例:
3
实验代码:
int countcs( struct ListNode *head ) { int sum=0; while(head!=NULL){ if(head->code[1]=='0'&&head->code[2]=='2') sum++; head=head->next; } return sum; }
设计思路:
遇到的问题及其解决方法:
对于while语句的程序框图还不太能理解
在网上查找这类问题
运行结果截图:
6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist(); struct ListNode *deleteeven( struct ListNode *head );
函数createlist
从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven
将单链表head
中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h> #include <stdlib.h> struct ListNode { int data; struct ListNode *next; }; struct ListNode *createlist(); struct ListNode *deleteeven( struct ListNode *head ); void printlist( struct ListNode *head ) { struct ListNode *p = head; while (p) { printf("%d ", p->data); p = p->next; } printf(" "); } int main() { struct ListNode *head; head = createlist(); head = deleteeven(head); printlist(head); return 0; } /* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
实验代码:
struct ListNode *createlist() { int x; struct ListNode *head,*tail,*p; head=(struct ListNode*)malloc(sizeof(struct ListNode)); head->next=NULL; tail=head; while(1) { p=(struct ListNode*)malloc(sizeof(struct ListNode)); scanf("%d",&x); p->next=NULL; if(x==-1) break; p->data=x; p->next=NULL; tail->next=p; tail=p; } return head; } struct ListNode *deleteeven( struct ListNode *head ) { struct ListNode *p1,*p2; int flag; p1=head; p2=p1->next; while(p1->next) { flag=0; if(p2->data%2==0) { p1->next=p2->next; p2=p2->next; flag=1; } if(flag==0) { p1=p1->next; p2=p1->next; } } return head->next; }
设计思路:无(不会)
遇到的问题及其解决方法:
本题的思路感觉很复杂,对于程序的运行过程不是很清楚,对单链表的使用还不是很熟练。
运行结果截图:
学习感悟:感觉对于c语言的学习还是缺乏耐心,应该给自己的每天一部分时间来练习,而不是被动的接受老师的知识,主动的学习才是真正的受用。
学习进度表: