hdu 1894 String Compare 还蛮不错的标题 STL 中的string应用

hdu 1894 String Compare 还蛮不错的题目 STL 中的string应用

String Compare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1789    Accepted Submission(s): 436


Problem Description
Maybe there are 750,000 words in English and some words are prefix of other words, for example: the word "acm" can be treat as one prefix of "acmicpc". What's more, most of such pairs of words have relationship between them. Now give you a dictionary, your work is to tell me how many such pairs.


There may be other characters in the word, for example '_','-',and so on.
Pay attention that 'A' and 'a' are not the same character!
 

Input
In the first line of the input file there is an Integer T, which means the number of test cases. Followed by T test cases.
For each test case, in the first line there is an integer N(0<N<=50000), followed N lines, each contains a word whose length is less than 30 and no space appears in any word. There are no same words in two different lines.
 

Output
For each test case, tell me how many such pairs. If the number is larger than 11519, just divide it by 11519 and only output the remainder.
 

Sample Input
2 2 acmicpc acm 3 a abc ab
 

Sample Output
1 3
 

Author
Sempr|CrazyBird|hust07p43
 

Source
HDU 2008-4 Programming Contest
 

Recommend
lcy

题意

: 一个单词是另一个单词的前缀 问这样的一共有多少对



思路

1:本题用字典树会超时

2:本题完全可以不用string  但是我想用这个题学习下string的应用

3: If the number is larger than 11519, just divide it by 11519 and only output the remainder

要特别注意这句话   大于11519才mod  等于不mod 因为这里我错12次 阿弥陀佛

#include<stdio.h>
#include<stdlib.h>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
string a[100010];
int main()
{
       int cas,i,j,n,cnt;
       cin>>cas;
       while(cas--)
       {
           cnt=0;
           cin>>n;
           for(i=0;i<n;i++)
               cin>>a[i];
               sort(a,a+n);
           for(i=0;i<n-1;i++)
           {
               for(j=i+1;j<n;j++)
               {
                   if(a[i].size()>=a[j].size()) break;
                    if(a[i].compare(0,a[i].size(),a[j],0,a[i].size())==0)//将a[i]与b[i]中的与a[i]长度相等的地方进行比较
                             cnt++;
                    else break;
                  
               }
                
           }
		   if(cnt>11519)  cnt=cnt%11519;
           printf("%d\n",cnt);
       }
       return 0;
}