HDU1276 士兵队列训练有关问题

HDU1276 士兵队列训练问题

士兵队列训练问题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3356    Accepted Submission(s): 1552


Problem Description
某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行一至三报数,凡报到三的出列,剩下的向小序号方向靠拢,继续从头开始进行一至二报数。。。,以后从头开始轮流进行一至二报数、一至三报数直到剩下的人数不超过三人为止。
 

Input
本题有多个测试数据组,第一行为组数N,接着为N行新兵人数,新兵人数不超过5000。
 

Output
共有N行,分别对应输入的新兵人数,每行输出剩下的新兵最初的编号,编号之间有一个空格。
 

Sample Input
2 20 40
 

Sample Output
1 7 19 1 19 37

#include <stdio.h>
#include <string.h>
bool arr[5002];
int n, ans;

int getNext(int i){
	while(arr[i] == 0 && i <= n) ++i;
	return i;
}

void cal2(){
	if(ans <= 3) return;
	for(int pos = 0; pos <= n; ){
		pos = getNext(pos + 1);
		if(pos > n) return;
		pos = getNext(pos + 1);
		if(pos > n) return;
		arr[pos] = 0;
		--ans;
	}
}

void cal3(){
	if(ans <= 3) return;
	for(int pos = 0; pos <= n; ){
		pos = getNext(pos + 1);
		if(pos > n) return;
		pos = getNext(pos + 1);
		if(pos > n) return;
		pos = getNext(pos + 1);
		if(pos > n) return;
		arr[pos] = 0;		
		--ans;
	}
}

int main(){
	int t, flag;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		ans = n;
		for(int i = 1; i <= n; ++i)
			arr[i] = 1;
		while(ans > 3){
			cal2();
			cal3();
		}
		flag = 0;
		for(int i = 0; ;){
			i = getNext(i + 1);
			if(i > n) break;
			if(flag == 0) flag = 1, printf("%d", i);
			else printf(" %d", i);
		}
		printf("\n");
	}
	return 0;
}