D - Fliptile POJ3279 搜索(反转开关经典有关问题,二进制表示集合)

D - Fliptile POJ3279 搜索(反转开关经典问题,二进制表示集合)

D - Fliptile
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3279

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1

0 0 0 0




//参考《挑战程序设计》一书,对该题的分析,解法

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<queue>
#include<cstdio>
#include<vector>
#include<algorithm>
#define bug printf("-----\n");
using namespace std;
const int maxn=20;
const int inf=210000;
typedef long long ll;
int m,n;
int opt[maxn][maxn];
int a[maxn][maxn];
int tmp[maxn][maxn];
int dx[]= {0,0,1,-1,0};
int dy[]= {-1,1,0,0,0};
int getcolor(int x,int y)
{
    int ans=a[x][y];
    for(int i=0; i<5; i++)
    {
        int xx=x+dx[i];
        int yy=y+dy[i];
        if(xx>=0&&xx<m&&yy>=0&&yy<n)
            ans+=tmp[xx][yy];
    }
    return ans%2;
}

int cal()
{
    int i,j;
    for(i=1; i<m; i++)
        for(j=0; j<n; j++)
            if(getcolor(i-1,j))
                tmp[i][j]=1;

    for(i=0;i<n;i++)
        if(getcolor(m-1,i))return -1;

    int ans=0;
    for(i=0;i<m;i++)
        for(j=0;j<n;j++)
        ans+=tmp[i][j];
    return ans;
}

void solve()
{
    int rec=-1;
    int i,j;
    for(i=0;i<1<<n;i++)
    {
        memset(tmp,0,sizeof(tmp));
        for(j=0;j<n;j++)
        {
            tmp[0][n-j-1]=i>>j&1;
        }
        int num=cal();
        if(num>=0&&(rec>num||rec<0))
        {
            rec=num;
            memcpy(opt,tmp,sizeof(tmp));
        }
    }
    if(rec<0)
        printf("IMPOSSIBLE\n");
    else
    {
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            printf("%d%c",opt[i][j],j==n?'\n':' ');
            printf("\n");
        }

    }
}


int main()
{
    int  i,j,t,k;
    while(~scanf("%d%d",&m,&n))
    {
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
                cin>>a[i][j];
        solve();
    }
    return 0;
}