HDU 1240 Asteroids

HDU 1240 Asteroids!

Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2275    Accepted Submission(s): 1548


Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.
 

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 

Sample Input
START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END
 

Sample Output
1 0 3 4 NO ROUTE
 

Source
South Central USA 2001
 

Recommend
zf
 解题思路:除了3维看似吓人外,就一BFS的水题,另外估计数据也很弱,0ms就过了。。。
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char maze[15][15][15];
bool visit[15][15][15];
long long depth[10000],Count,s;
int mov[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};//前,后,左,右,上,下
int BFS(int xa,int ya,int za,int xb,int yb,int zb)
{
	int a,b,c,i=1,j,p,q,r;
	bool flag=false;
	queue<int> x;queue<int> y;queue<int> z;
	x.push(xa);y.push(ya);z.push(za);
	while(!x.empty()&&!y.empty()&&!z.empty())
	{
		if(Count==depth[i-1])
		{
			i++;
			Count=s=0;
		}
		a=x.front();b=y.front();c=z.front();
		x.pop();y.pop();z.pop();
		if(a==xb&&b==yb&&c==zb)
		{
			flag=true;
			break;
		}
		for(j=0;j<6;j++)
		{
			p=a+mov[j][0];q=b+mov[j][1];r=c+mov[j][2];
			if(maze[p][q][r]=='O'&&!visit[p][q][r])
			{
				visit[p][q][r]=true;
				x.push(p);y.push(q);z.push(r);
				s++;
			}
		}
		depth[i]=s;
		Count++;
	}
	if(flag)
	    return i-1;
	else
		return -1;
}
int main()
{
	int i,j,k,n,sx,sy,sz,ex,ey,ez,ans;
	char cmd[10];
	while(cin>>cmd)
	{
		cin>>n;
		memset(maze,'*',sizeof(maze));
		memset(visit,false,sizeof(visit));
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				for(k=0;k<n;k++)
					cin>>maze[k][j][i];
		cin>>sx>>sy>>sz>>ex>>ey>>ez;
		cin>>cmd;
		visit[sx][sy][sz]=true;
		depth[0]=1;
		Count=s=0;
		ans=BFS(sx,sy,sz,ex,ey,ez);
		if(ans==-1)
			cout<<"NO ROUTE"<<endl;
		else
			cout<<n<<" "<<ans<<endl;
	}
	return 0;
}