HDU 1253:取胜大逃亡(简单三维BFS)

HDU 1253:胜利大逃亡(简单三维BFS)

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24937    Accepted Submission(s): 9535


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

HDU 1253:取胜大逃亡(简单三维BFS)

 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
11
 

这题我TM逗比的犯那种逗比错误。。忘记打return 0;了 。。。不知道是不是不小心删了。。。

代码其实没什么好说的。。简单的BFS。。



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

const int maxn = 51;
const int INF = 0x3f3f3f3f;
int map[maxn][maxn][maxn];//地图
int vist[maxn][maxn][maxn];//标记数组
int a, b, c;//x,y,z
int mintime;//魔王回来的时间
int ans;
int dx[]= {1,-1,0,0,0,0};
int dy[]= {0,0,0,0,-1,1};
int dz[]= {0,0,-1,1,0,0};
int xx, yy, zz;

struct point
{
    int x, y, z;
    int time;
};
queue<point>q;

int bfs()
{
    while( !q.empty() )
    {
        point temp = q.front();
        q.pop();
        if( temp.x == a-1 && temp.y == b-1 && temp.z == c-1 && temp.time<=mintime)
            return temp.time;
        for(int i=0; i<6; i++)
        {
            xx = temp.x + dx[i];
            yy = temp.y + dy[i];
            zz = temp.z + dz[i];
            if( xx>=0 && xx<a && yy>=0 && yy<b && zz>=0 && zz<c && map[xx][yy][zz]!=1 && !vist[xx][yy][zz] )
            {
                point next;
                next.x = xx;
                next.y = yy;
                next.z = zz;
                next.time = temp.time + 1;
                vist[xx][yy][zz] = 1;
                q.push( next );
            }
        }
    }
    return -1;
}

int main()
{
    int cas;
    scanf("%d", &cas);
    while( cas-- )
    {
        while( !q.empty() ) q.pop();
        memset(map, 0, sizeof(map));
        memset(vist, 0, sizeof(vist));
        scanf("%d%d%d%d", &a, &b, &c, &mintime);
        for(int i=0; i<a; i++)
            for(int j=0; j<b; j++)
                for(int k=0; k<c; k++)
                    scanf("%d", &map[i][j][k]);
        if( map[a-1][b-1][c-1]==1 )
        {
            printf("-1\n");
            continue;
        }
        if( a==1 && b==1 && c==1)
        {
            printf("0\n");
            continue;
        }
        point start;
        start.x = 0;
        start.y = 0;
        start.z = 0;
        start.time = 0;
        q.push( start );
        vist[0][0][0] = 1;
        ans = bfs();
        printf("%d\n", ans);
    }
    return 0;
}