(Catalan数 大数) Game of Connections poj2084

Language:

Game of Connections

Time Limit: 1000MS

Memory Limit: 30000K

Total Submissions: 8837

Accepted: 4358

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another.

And, no two segments are allowed to intersect.

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1.

You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2

3

-1

Sample Output

2

5

java,卡特兰数

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {                 //java的基础部分要好好扎实。
        Scanner in=new Scanner(System.in);
        BigInteger a[]=new BigInteger[101];
        a[0]=BigInteger.valueOf(0);
        a[1]=BigInteger.valueOf(1);
        int n;
        while(in.hasNextInt()) {
            n=in.nextInt();
            if(n==-1)
                break;
            for(int i=2;i<=n;i++) {
                a[i]=a[i-1].multiply(BigInteger.valueOf(i*4-2)).divide(BigInteger.valueOf(i+1));
            }
            System.out.println(a[n]);
        }
    }
}