HDOJ 3549 Flow Problem Flow Problem



Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 5713    Accepted Submission(s): 2670


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1
 

Sample Output
Case 1: 1
Case 2: 2
 

Author
HyperHexagon
 

Source
 

Recommend
zhengfeng
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int INF=0x3f3f3f3f;
const int MaxV=10000,MaxE=11000;

struct Edge
{
    int to,next,flow;
};

Edge E[MaxE+10];
int Size,Adj[MaxV+10],src,sink,dist[MaxV+10];
bool vis[MaxV+10];

void Init()
{
    Size=0;
    memset(Adj,-1,sizeof(Adj));
}

void Add_Edge(int u,int v,int c)
{
    E[Size].to=v;
    E[Size].next=Adj;
    E[Size].flow=c;
    Adj=Size++;
    E[Size].to=u;
    E[Size].next=Adj[v];
    E[Size].flow=0;
    Adj[v]=Size++;
}

void bfs()
{
    memset(dist,0,sizeof(dist));
    memset(vis,false,sizeof(vis));
    queue<int> q;
    q.push(src);  vis[src]=true;
    while(!q.empty())
    {
        int u=q.front(); q.pop();
        for(int i=Adj;~i;i=E.next)
        {
            int v=E.to;
            if(E.flow&&!vis[v])
            {
                vis[v]=true;
                q.push(v);
                dist[v]=dist+1;
            }
        }
    }
}

int dfs(int u,int delta)
{
    if(u==sink)
    {
        return delta;
    }
    else
    {
        int ret=0;
        for(int i=Adj;~i&&delta;i=E.next)
        {
            int v=E.to;
            if(E.flow&&dist[v]==dist+1)
            {
                int dd=dfs(v,min(delta,E.flow));
                E.flow-=dd; E[i^1].flow+=dd;
                delta-=dd; ret+=dd;
            }
        }
        return ret;
    }
}

int maxflow()
{
    int ret=0;
    while(true)
    {
        bfs();
        if(vis[sink]==falsereturn ret;
        ret+=dfs(src,INF);
    }
}

int main()
{
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        Init();
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            Add_Edge(a,b,c);
        }
        src=1,sink=n;
        printf("Case %d: %d ",cas++,maxflow());
    }

    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )