hdu 1160 FatMouse's Speed(最细高挑儿序列+路劲打印)

hdu 1160 FatMouse's Speed(最长子序列+路劲打印)

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10081    Accepted Submission(s): 4487
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
4 4 5 9 7
 

Source
Zhejiang University Training Contest 2001
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:  1024 1074 1025 1081 2059 
 
题意:求符合老鼠a[i]的重量>a[j]的重量&&a[i]的速度<a[j]的速度的最长序列。
题解:先重量从大到小排,再速度从小到大排序。然后求最长子序列。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#define N 1100
using namespace std;

int n;
int dp[N],Next[N];

struct edge {
    int si,sp;
    int num;
} a[N];

bool cmp(edge a,edge b) {
    if(a.si==b.si)
        return a.sp>b.sp;
    return a.si<b.si;
}

bool ok(int i,int j) {
    return (a[i].si>a[j].si)&&(a[i].sp<a[j].sp);
}

void Print(int x) {
    if(Next[x]==-1) {
        printf("%d\n",a[x].num);
        return;
    }
    Print(Next[x]);
    printf("%d\n",a[x].num);
}

int main() {
    n=0;
    int x,y;
    while(scanf("%d%d",&a[n].si,&a[n].sp)!=EOF) {
        a[n].num=n+1;
        n++;
    }
    sort(a,a+n,cmp);
    memset(Next,-1,sizeof Next);
    int ans=0,first;
    for(int i=0; i<n; i++) {
        dp[i]=1;
        for(int j=0; j<i; j++) {
            if(ok(i,j)&&dp[i]<dp[j]+1) {
                dp[i]=dp[j]+1;
                Next[i]=j;
            }
        }
        if(ans<dp[i])ans=dp[i],first=i;
    }
    printf("%d\n",ans);
    //printf("first=%d\n",first);
    Print(first);
    return 0;
}