Red and Black(简单dfs) Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12519    Accepted Submission(s): 7753


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

 

Sample Output
45 59 6 13
简单dfs,无剪枝;
代码:
#include<stdio.h>
char map[21][21];
int
dir[4][2]={1,0,-1,0,0,1,0,-1},step,W,H;
void
dfs(int x,int y){
    int
tx,ty;
    step++;
    for
(int i=0;i<4;++i){
        tx=x+dir[i][0];ty=y+dir[i][1];
        if
(tx>=W||ty>=H||tx<0||ty<0||map[ty][tx]=='#'||map[ty][tx]=='@')continue;
        map[ty][tx]='@';
        dfs(tx,ty);
    }
}

int
main(){int x,y;
    while
(scanf("%d%d",&W,&H),W||H){step=0;
        for
(int i=0;i<H;++i)scanf("%s",map[i]);
        for
(int i=0;i<H;++i)for(int j=0;j<W;++j)if(map[i][j]=='@')x=j,y=i;
        dfs(x,y);
        printf("%d ",step);
    }

    return
0;
}