(KMP 1.5)hdu 1358 Period(使用next数组回求最小循环节——求到第i个字符的循环节数)

(KMP 1.5)hdu 1358 Period(使用next数组来求最小循环节——求到第i个字符的循环节数)

题目:

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3813    Accepted Submission(s): 1862


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
3 aaa 12 aabaabaabaab 0
 

Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  3336 3068 2203 1277 1867 


题目分析:

         KMP。简单题。这一道题其实和KMP 1.4那道题的思想是一样的。



代码如下:

/*
 * hdu1358.cpp
 *
 *  Created on: 2015年4月18日
 *      Author: Administrator
 */




#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 1000001;

int m;//目标串的长度

char pattern[maxn];//模式串
int nnext[maxn];//next数组.直接起next可能会跟系统中预定的重名.

/*O(m)的时间求next数组*/
void get_next() {
	m = strlen(pattern);

	nnext[0] = nnext[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = nnext[i];
		while (j && pattern[i] != pattern[j])
			j = nnext[j];
		nnext[i + 1] = pattern[i] == pattern[j] ? j + 1 : 0;
	}
}


int main(){
	int cnt = 1;

	while(scanf("%d",&m)!=EOF,m){
		scanf("%s",pattern);
		get_next();

		printf("Test case #%d\n",cnt++);
		/**
		 * 遍历next数组。
		 * 输出循环节数>=2的情况
		 */
		int i;
		for(i = 0 ; i <= m ; ++i){
			if(nnext[i] == 0){
				continue;
			}

			int len = i - nnext[i];
			if(i%len == 0){
				printf("%d %d\n",i,i/len);
			}
		}
		printf("\n");
	}
}