zoj3822||牡丹江市现场赛D题 概率dp

zoj3822||牡丹江现场赛D题 概率dp

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5376

Domination

Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667
/**
zoj 3822
题意:问把一个n*m的棋盘填成每行至少一个棋子,每列至少一个棋子的状态,需要棋子的数学期望
解题思路: dp[i][j][k]表示到达结果状态时所需要的棋子数的期望值。那么dp[0][0][0]就是结果,状态转移方程见代码。
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int T,n,m;
double dp[55][55][2555];
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        for(int i=n; i>=0; i--)
        {
            for(int j=m; j>=0; j--)
            {
                if(j==m&&n==i)
                    continue;
                for(int t=i*j; t>=max(i,j); t--)
                {
                    dp[i][j][t]+=dp[i][j][t+1]*1.0*(i*j-t)/(n*m-t);
                    dp[i][j][t]+=dp[i][j+1][t+1]*1.0*(m-j)*i/(n*m-t);
                    dp[i][j][t]+=dp[i+1][j][t+1]*(1.0)*(n-i)*j/(n*m-t);
                    dp[i][j][t]+=dp[i+1][j+1][t+1]*(1.0)*(n-i)*(m-j)/(n*m-t);
                    dp[i][j][t]+=1.0;
                }
            }
        }
        printf("%.12lf\n",dp[0][0][0]);
    }
    return 0;
}