hdu4027 Can you answer these queries?(线段树平方减小,区间求和)

hdu4027 Can you answer these queries?(线段树平方减少,区间求和)

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4027

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 
Sample Output
Case #1: 19 7 6


代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0x3fffffff
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
//lson和rson分辨表示结点的左儿子和右儿子
//rt表示当前子树的根(root),也就是当前所在的结点
const __int64 maxn = 111111;
//maxn是题目给的最大区间,而节点数要开4倍,确切的来说节点数要开大于maxn的最小2x的两倍

__int64 sum[maxn<<2];

void PushUp(int rt) //把当前结点的信息更新到父结点
{
	sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
	if (l == r)
	{
		scanf("%I64d",&sum[rt]);
		return ;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}
void update(int L,int R,int l,int r,int rt) 
{
	if(l == r)
	{
		sum[rt]=sqrt(sum[rt]);
		return ;
	}
	int m = (l + r) >> 1;
	if (L <= m)
		update(L , R , lson);
	if (m < R) 
		update(L , R , rson);
	PushUp(rt);
}
__int64 query(int L,int R,int l,int r,int rt)
{
	if (L <= l && r <= R)
	{
		return sum[rt];
	}
	int m = (l + r) >> 1;
	__int64 ret = 0;
	if (L <= m) 
		ret += query(L , R , lson);
	if (m < R)
		ret += query(L , R , rson);
	return ret;
}
int main() 
{
	int N , Q ,T , K=0;
	int a , b , c;
	while(~scanf("%d",&N) && N)
	{
		build(1 , N , 1);//建树
		printf("Case #%d:\n",++K);
		scanf("%d",&Q);
		while (Q--)//Q为询问次数
		{
			//	char op[2];
			int op;
			int a , b , c;
			scanf("%d%d%d",&op,&a,&b);
			if(a > b)
			{
				int t;
				t = a, a = b, b = t; 
			}
			if (op == 1) 
			{
				printf("%I64d\n",query(a , b , 1 , N , 1));
			}
			else
			{
				if(query(a , b , 1 , N , 1) != b-a+1)
					update(a , b , 1 , N , 1);
			}
		}
		printf("\n");
	}
	return 0;
}