杭电1004-Let the Balloon Rise

杭电1004---Let the Balloon Rise
Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output

red
pink
Source

WU, Jiazhi

Recommend

JGShining

分析:第一次做的时候,我对输入的字符串进行排序,刚开始以为排序后容易找那个颜色的次数最多,样例过了,可是一直wrong,这个不能排序,打乱输入的顺序。。。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
    string a[1050];
    int num[1050];
    int n;
    while(cin>>n)
    {
        getchar();
        memset(num,0,sizeof(num));
        if(n==0)
            break;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(a[i]==a[j])
                    num[i]++;
            }
        }
          int max=0;
          int k=0;
          for(int i=0;i<n;i++)
          {
              if(max<num[i])
              {
                  k=i;
                  max=num[i];
              }
          }
          cout<<a[k]<<endl;
    }
    return 0;
}