A1027Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

思路:

因为转换成十三进制之后最多有两位,即num/13和num%13,所以边输入边转换输出,又因为10 11 12由ABC表示,所以用一个字符数组做映射。注意,输出中#可以先输出,在循环输入输出之前输出可以AC,只要在输出部分位置正确即可。

 

#include <iostream>
using namespace std;
int main() {
    int num;
    char mp[14] = { "0123456789ABC" };
    cout << "#";
    for (int i = 0; i < 3; i++) {
        cin >> num;
        cout<< mp[num / 13] << mp[num % 13];
    }
    return 0;
}