poj3140-Contestants Division(树形dp-水题)

poj3140--Contestants Division(树形dp-水题)
Contestants Division
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8469   Accepted: 2420

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

 

给出n个点,m条无向边,m实际上就是n-1,组成的一棵树,拆掉一条边后,树会变为两个,问两个树的差最小是多少?

直接记录一下总和,然后深搜一下就可以了

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL __int64
struct node{
    int v , next ;
}edge[210000] ;
int head[110000] , cnt , vis[210000];
LL c[110000] , min1 , ans ;
void add(int u,int v) {
    edge[cnt].v = v ; edge[cnt].next = head[u] ;
    head[u] = cnt++ ;
    edge[cnt].v = u ; edge[cnt].next = head[v] ;
    head[v] = cnt++ ;
    return ;
}
LL f(LL a) {
    return a >= 0 ? a : -a ;
}
void dfs(int u) {
    int i ;
    LL temp ;
    for(i = head[u] ; i != -1 ; i = edge[i].next) {
        if( vis[i] == 0 ) {
            vis[i] = vis[i^1] = 1 ;
            dfs(edge[i].v) ;
            temp = f(ans-c[edge[i].v]-c[ edge[i].v ]) ;
            if( temp < min1 ) min1 = temp ;
            c[u] += c[ edge[i].v ] ;
        }
    }
}
int main() {
    int n , m , t = 0 , i , j , u , v ;
    while( scanf("%d %d", &n, &m) != EOF ) {
        if( n == 0 && m == 0 ) break ;
        memset(head,-1,sizeof(head)) ;
        memset(vis,0,sizeof(vis)) ;
        cnt = 0 ;
        ans = 0 ;
        for(i = 1 ; i <= n ; i++) {
            scanf("%I64d", &c[i]) ;
            ans += c[i] ;
        }
        min1 = ans ;
        while( m-- ) {
            scanf("%d %d", &u, &v) ;
            add(u,v) ;
        }
        dfs(1) ;
        printf("Case %d: %I64d\n", ++t, min1) ;
    }
    return 0 ;
}