PAT 1138 Postorder Traversal

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

#include<iostream> //海星
#include<vector>
using namespace std;
vector<int> pre,in;
int flag=0;
void solve(int lb, int le, int rb, int re){
	if(lb>le)
		return ;
	if(lb==le&&flag++==0)
		cout<<pre[lb]<<endl;
	int i=rb;
	while(i<=re&&in[i]!=pre[lb]) i++;
	solve(lb+1, lb+i-rb, rb, i-1);
	solve(lb+i-rb+1, le, i+1, re);
}
int main(){
	int n;
	cin>>n;
	pre.resize(n), in.resize(n);
	for(int i=0; i<n; i++)
		cin>>pre[i];
	for(int i=0; i<n; i++)
		cin>>in[i];
	solve(0, n-1, 0, n-1);
	return 0;
}