NYOJ-Registration system

NYOJ--Registration system

Registration system

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述

A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

 The site administration wants to launch their project as soon as possible, that's why they

 ask you to help. You're suggested to implement the prototype of site registration system. 

The system should work on the following principle.

Each time a new user wants to register, he sends to the system a request with his name.

 If such a name does not exist in the system database, it is inserted into the database, and 

the user gets the response OK, confirming the successful registration. If the name already 

exists in the system database, the system makes up a new user name, sends it to the user 

as a prompt and also inserts the prompt into the database. The new name is formed by the

 following rule. Numbers, starting with 1, are appended one after another to name (name1,

 name2, ...), among these numbers the least i is found so that namei does not yet exist in

 the database.

输入
The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
输出
Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
样例输入
4
abacaba
acaba
abacaba
acab
样例输出
OK
OK
abacaba1
OK
解析:这道题目属于STL分类的,应该算是基础题目,这道题在一点上容易出错,当输入第二次输入ab后返回ab1,当再次输入ab1时应该返回ab11,把这点考虑到基本就没什么问题了。
#include <iostream>
#include <string>
#include <vector>
using std::vector;
using std::cout;
using std::endl;
using std::cin;
using std::string;
using std::iterator;
//查找容器中的元素
bool findElement(vector<string>::iterator beg,vector<string>::iterator end,string elem)
{
	for(vector<string>::iterator ivec = beg; ivec != end; ivec++)
	{
		if(elem == *ivec)
		{
			return true;
		}
	}
	return false;
}
int main()
{
	int cnt=1;
	int N;
	vector<string> vStr;
	vector<string>::iterator beg = vStr.begin();
	vector<string>::iterator end = vStr.end();
	cin >> N;
	while(N--)
	{
		string str;
		cin >> str;
		//查找容器中是否有该字符串
		if(findElement(beg,end,str))
		{//如果存在
			//保存输入的字符串
			string tempStr(str);
			while(1)
			{
				//返回替代的字符串
				tempStr+=(cnt++)+'0';
				if(!findElement(beg,end,tempStr))
				{//如果替代的字符串在vector中不存在则输出重置cnt
					cnt=1;
					cout<< tempStr <<endl;
					str = tempStr;
					break;
				}else{
					//如果替代字符串还是存在则用原来输入的字符串继续加cnt
					tempStr = str;
				}
			}
		}else{
			//如果不存在
			cout<< "OK" <<endl;
		}
		//添加元素更新迭代器
		vStr.push_back(str);
		beg = vStr.begin();
		end = vStr.end();
	}
	return 0;
}