hdu4268 Alice and Bob 长春市网络赛

hdu4268 Alice and Bob 长春网络赛

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 406    Accepted Submission(s): 161


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.

Output
For each test case, output an answer using one line which contains just one number.

Sample Input
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4

Sample Output
1 2

Source
2012 ACM/ICPC Asia Regional Changchun Online

Recommend
liuyiding
 
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<vector>
#include<set>
#include<algorithm>
#include<map>
using namespace std;
typedef pair<int,int>qiqi;
vector<qiqi>a,b;
multiset<int>c;
multiset<int>::iterator it;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        a.clear();b.clear();
        int h,w;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&h,&w);
            a.push_back(make_pair(h,w));
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&h,&w);
            b.push_back(make_pair(h,w));
        }
        sort(a.begin(),a.end());
        sort(b.begin(),b.end());
        int ans=0;
        c.clear();
        int j=0;
        for(int i=0;i<a.size();i++)
        {
            while(j<b.size()&&b[j].first<=a[i].first)
            {
                c.insert(b[j].second);
                j++;
            }
            it=c.upper_bound(a[i].second);
            if(it!=c.begin()&&!c.empty())
            {
                it--;
                c.erase(it);
                ans++;
            }
        }
        printf("%d\n",ans);
    }
}