标题1005:Graduate Admission

题目1005:Graduate Admission

题目1005:Graduate Admission

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:2428

解决:686

题目描述:

    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4
来源:
2011年浙江大学计算机及软件工程研究生机试真题

/********************************* 
*   日期:2013-2-27
*   作者:SJF0115 
*   题号: 九度OJ 题目1005:Graduate Admission
*   来源:http://ac.jobdu.com/problem.php?pid=1005
*   结果:AC 
*   来源:2011年浙江大学计算机及软件工程研究生机试真题
*   总结: 
**********************************/ 
#include <stdio.h>
#include <stdlib.h>

//结构体
typedef struct Application{
	int GI;//复试成绩
	int GE;//初试成绩
	int GF;//总成绩
	int PS[6];//偏爱的学校
	int ID;//编号
}Application;

typedef struct School{
	int Quota;//学校名额
	int count;//实际招收人数
	int AppID[4001];//招收人的ID
}School;

Application app[40001];
School school[101];
//排序函数
int cmp(const void *a, const void *b){
	struct Application *c = (Application *)a;
	struct Application *d = (Application *)b;
	if(c->GF != d->GF){
		return d->GF - c->GF;
	}
	else if(c->GE != d->GE){
		return d->GE - c->GE;
	}
}
int cmp2(const void *a,const void *b){
	return *(int *)a - *(int *)b;
}
int main () {
	//N  the total number of applicants;
	//M  the total number of graduate schools
	//K  the number of choices an applicant may have.
    int N,M,K,i,j,SID; 
    while(scanf("%d %d %d",&N,&M,&K) != EOF){
		//每个学校的名额
		for(i = 0;i < M;i++){
			scanf("%d",&school[i].Quota);
			school[i].count = 0;
		}
		for(i = 0;i < N;i++){
			//初试成绩 复试成绩
			scanf("%d %d",&app[i].GE,&app[i].GI);
			//总成绩
			app[i].GF = (app[i].GE + app[i].GI) / 2;
			//偏爱的学校
			for(j = 0;j < K;j++){
				scanf("%d",&app[i].PS[j]);
			}
			app[i].ID = i;
		}//for
		//排序
		qsort(app,N,sizeof(app[0]),cmp);
		//安排招生
		for(i = 0;i < N;i++){
			for(j = 0;j < K;j++){
				SID = app[i].PS[j];
				//如果SID学校还没有招满
				if(school[SID].Quota > 0){
					school[SID].AppID[school[SID].count] = i;
					school[SID].count ++;
					school[SID].Quota --;
					break;
				}
				//已经招满
				else{
					//最后一个招生人的ID
					int index = school[SID].AppID[school[SID].count - 1];
					//如果所有成绩都一样,即使学校已经招满一样被录取
					if(app[i].GF == app[index].GF && app[i].GE == app[index].GE){
						school[SID].AppID[school[SID].count] = i;
						school[SID].count ++;
						school[SID].Quota --;
						break;
					}
				}
			}//for
		}//for
		for(i = 0;i < M;i++){
			for(j = 0;j < school[i].count;j++){
				school[i].AppID[j] = app[school[i].AppID[j]].ID;
			}
		}
		//输出学校招收情况
		for(i = 0;i < M;i++){
			//该学校没有招收到学生
			if(school[i].count == 0){
				printf("\n");
			}
			//该学校招收到1名学生
			else if(school[i].count == 1){
				printf("%d\n",school[i].AppID[0]);
			}
			//该学校招收到大于1名学生,需排序安编号大小输出
			else{
				//排序输出
				qsort(school[i].AppID,school[i].count,sizeof(int),cmp2);
				int first = 1;
				for(j = 0;j < school[i].count;j++){
					if(first){
						first = 0;
					}
					else{
						printf(" ");
					}
					printf("%d",school[i].AppID[j]);
				}
				printf("\n");
			}
		}//for
    }//while
    return 0;
}


注意:

考虑到边界条件比如
11 6 3
0 0 0 2 2 3
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
100 100 0 1 2
学校0,1,2招生人数都为零,11个学生没一个能录取。