ACM HDU 1022,该怎么处理

ACM HDU 1022
http://acm.hdu.edu.cn/showproblem.php?pid=1022
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.



Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input
3 123 321
3 123 312
 

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint 
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


#include<iostream>
#include<string>
#include<stack>
using namespace std;

int main()
{
int n;
char a[12],b[12];
string str[200];
while(cin >> n >> a >>b)
{
stack<char>zq;
int flag=0;
int i,j=0,k=0;
int len1 =strlen(a);
for(i=0;i<len1;i++)
{
if(a[i] != b[j])
{
zq.push(a[i]);
str[k++]="in";
}
else
{
j++;
str[k++]="in";
str[k++]="out";
}
}
while(!zq.empty())
{
char c=zq.top();
if(c != b[j])
{
flag=1;
break;
}
zq.pop();
str[k++]="out";
j++;
}
if(flag)
cout<<"No."<<endl;
else
cout<<"Yes."<<endl;
if(!flag)
{
for(i=0;i<k;i++)
cout<<str[i]<<endl;
}
cout<<"FINISH"<<endl;
}
return 0;
}


------解决方案--------------------
大体的算法没有问题
只是有一个缺陷:没判断b串是否也处理完毕
比如
3 123 3214
严格来说4是不可能作为一个出栈序号的,所以这样也是No.
试试看这样能解决问题否。
------解决方案--------------------
以下输入处理错了:
3 123 213
------解决方案--------------------
个人觉得这题的解题思想是:针对每个数n,则其右侧小于n的数必然逆序排列(可用递归解决)
ex:
输入12345 -> 34125 :由于1、2比3小且1、2在3的右侧,则1、2必须逆序,故此序列(34125)不存在,