Sicily课程练习 1509. Rails Constraints Description Input Output Sample Input Sample Output Problem Source

Time Limit: 1 secs, Memory Limit: 32 MB

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

Sicily课程练习 1509. Rails
Constraints
Description
Input
Output
Sample Input
Sample Output
Problem Source

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 
The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

Problem Source

Central Europe 1997

题目大意:

搞得这么一大串英文。。。是要吓死人么!!给定N只火车,按照1到N的顺序入栈,给你出栈顺序,要求出栈顺序是否匹配入栈顺序。输入包含多个块,每个块第一行是列车数目,接下来是多行出栈序列,匹配输出Yes,否则输出No,每个块输出结束后有一个空行,NULL块后面没有任何输出。

思路:

还是模拟。先把出栈序列存在表,开个stack来模拟入栈的操作,如果两者的头相同,就都pop,每次pop之后还要检查pop之后的头是否再次匹配。

代码+少量注释:

#include <iostream>
#include <stack>
#include <list>
using namespace std;

int main(){
    list<int> outtrain;
    stack<int> intrain;
    int i, numoftrain, train;

    while(1){
        cin >> numoftrain;
        if(numoftrain == 0)
            break;

        while(1){
          cin >> train;

          if(train == 0){
            cout << endl;
            break;
          }
          outtrain.push_back(train);//初始化出栈列车顺序
          for(i = 1; i < numoftrain;i++){
            cin >> train;
            outtrain.push_back(train);
          }

          for(i = 1;i <= numoftrain;i++){
            intrain.push(i);//若i与出栈序列的头匹配,则要pop掉i,但是还要检查pop之后两者的头是否会相等
            while((!intrain.empty()) && (!outtrain.empty()) && intrain.top() == outtrain.front()){
                intrain.pop();
                outtrain.pop_front();
            }
          }

          if(intrain.empty())
            cout << "Yes" << endl;
          else
            cout << "No" << endl;

          while(!intrain.empty())//每个测试用例都要用到栈和表,每次用完都要pop干净
            intrain.pop();
          while(!outtrain.empty())
            outtrain.pop_front();
        }
    }
      system("pause");
    return 0;
}