ACM-BFS之得胜大逃亡——hdu1253

ACM-BFS之胜利大逃亡——hdu1253
胜利大逃亡
题目:http://acm.hdu.edu.cn/showproblem.php?pid=1253
Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

ACM-BFS之得胜大逃亡——hdu1253
Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11


很水很水的广搜题目,就是将二维广搜变成三维的就行了,六个方向,前后左右上下。。。


#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
int a,b,c,t;
struct Coor
{
    int x,y,z,step;
};
int mapp[51][51][51],dis[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
bool vis[51][51][51];

bool judge(int x,int y,int z)
{
    if(x<0 || y<0 || z<0 || x>=a || y>=b || z>=c)   return 0;
    if(vis[x][y][z] || mapp[x][y][z])   return 0;
    return 1;
}

int bfs(int x,int y,int z)
{
    queue <Coor> q;
    Coor pre,next;
    int i;

    pre.x=x;
    pre.y=y;
    pre.z=z;
    pre.step=0;
    vis[x][y][z]=1;
    q.push(pre);

    while(!q.empty())
    {
        pre=q.front();
        q.pop();
        if(pre.x==a-1 && pre.y==b-1 && pre.z==c-1)  return pre.step;
        if(pre.step>t)    return -1;
        for(i=0;i<6;++i)
        {
            next.x=pre.x+dis[i][0];
            next.y=pre.y+dis[i][1];
            next.z=pre.z+dis[i][2];
            if(judge(next.x,next.y,next.z))
            {
                next.step=pre.step+1;
                vis[next.x][next.y][next.z]=1;

                q.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    int i,j,k,sl;
    scanf("%d",&sl);
    while(sl--)
    {
        scanf("%d%d%d%d",&a,&b,&c,&t);
        for(i=0;i<a;++i)
            for(j=0;j<b;++j)
                for(k=0;k<c;++k)
                    scanf("%d",&mapp[i][j][k]);

        memset(vis,0,sizeof(vis));
        printf("%d\n",bfs(0,0,0));
    }
    return 0;
}