POJ 1328Radar Installation(贪心好标题)

POJ 1328Radar Installation(贪心好题目)
Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44740   Accepted: 9922

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
POJ 1328Radar Installation(贪心好标题) 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1



题目大意:平面上有一些点,现要求用一些圆心在x轴上的圆(雷达)
来覆盖这些点,问最少需要多少雷达

解题思路:每个雷达尽量覆盖更多的点,先对点按x坐标排序,在最左
边建一个雷达,在雷达左边的点可以覆盖,只需要将雷达左移即可。
但是在雷达右边的却需要新建立雷达。具体实现见代码。

题目地址:Radar Installation

AC代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

const double eps=1e-6;
struct mq
{
    double x;
    double y;
};
mq node[1002];

bool cmp(mq a,mq b)
{
    if(a.x<b.x) return true;
    return false;
}

double dis(double xx,double x,double y)
{
    return sqrt(y*y+(xx-x)*(xx-x));
}

int main()
{
    int tes=0,n,i;
    double d;
    double xx;
    while(scanf("%d%lf",&n,&d))
    {
        int res=1,flag=0;
        if(n==0&&d<eps) break;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&node[i].x,&node[i].y);
            if(node[i].y-d>eps) flag=1;
        }
        printf("Case %d: ",++tes);
        if(flag) {puts("-1"); continue;}  //说明圆包括不了
        sort(node,node+n,cmp);

        xx=node[0].x+sqrt(d*d-node[0].y*node[0].y);
        for(i=1;i<n;i++)
        {
            double tmp;
            tmp=node[i].x+sqrt(d*d-node[i].y*node[i].y);
            if(dis(xx,node[i].x,node[i].y)>d)  //说明覆盖不了
            {
                if(tmp>xx) res++;  //需要重新建立一个雷达
                xx=tmp;   
            }
        }
        printf("%d\n",res);
    }
    return 0;
}

/*
2 5
-3 4
-6 3
*/

//47MS