HDU 1159 Common Subsequence

HDU 1159 Common Subsequence .

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8893    Accepted Submission(s): 3578

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0
 

 

Source
Southeastern Europe 2003
 

 

Recommend
Ignatius
 
呢个系DP既一种经典题型,叫LCS(Longest Common Subsequence)最长公共子序列,系允许吾连续,连续又系另外一种鸟。
首先就系要提到一种叫做最优子结构既性质,相当好用正斗既性质。
 
设X = <x1, x2, ........xm>, Xm-1 = <x1, x2, .........xm-1>
    Y = <y1, y2, ........yn>, Yn-1 = <y1, y2, .........yn-1>
    Z = <z1, z2, ........zk>, Zk-1 = <z1, z2, ........zk>
 
另外Z为X,Y既LCS,就可以引出如下性质:,
 
1、当xm = ym既时候, Zk-1为Xm-1同埋Yn-1既LCS。(因为zk就系xm(ym), 呢种情况Z = Zk-1 + 1)
2、当xm != ym既时候, Z就系 "Xm-1同Y” 或者  "X同Yn-1" 既LCS。(即系两种可能之间既最大值)
 
根据呢两个性质就可以即刻写出一个递归定义:
两个序列既LCS包含左两个序列前序既然LCS。
姐系甘,你要求XY既LCS,就首先要求出"Xm-1同 Yn-1"、 "Xm-1同Y” 或者  "X同Yn-1"既LCS。
写成递归式就系下面甘样:
 
设ts[i][j]储存Xi同Yi既LCS长度。
               {          ts[i][j] = 0                                           i = 0 || j = 0        //注意呢度可以解决空集情况
ts[i][j] = {           ts[i][j] = ts[i][j]                                     xi = yi
               {          ts[i][j] = Max(ts[i][j - 1], ts[i - 1][j])    xi != yi 
 
但系如果字符串好大, 写递归好明显吾得吃,所以用二维数组递推,时间复杂度O(n*m)。
 
下面系代码:
 
4226991 2011-07-20 15:59:19 Accepted 1159 62MS 24556K 952 B C++ 10SGetEternal{(。)(。)}!
 
#include <iostream>
#include <string>
using namespace std;

#define MAXF(x, y) (x > y? x: y)

string x, y;
int    lx, ly, **ts;

void print(int *arr, int siz)
{
 int i;

 for (i = 0; i < siz; i++)
  printf("%6d", arr[i]);
 putchar('\n');
}

void init()
{
 int i;
 
 lx = x.length();
 ly = y.length();
 ts = new int *[lx + 1];
 for (i = 0; i < lx + 1; i++)
 {
  ts[i] = new int [ly + 1];
  memset(ts[i], 0, sizeof(int) * (ly + 1));
#if 0
  print(ts[i], ly + 1);
#endif
 }
}

int dp()
{
 int i, j;
 
#if 0
 printf("test  = %d\n", MAXF(8, 7));
#endif
 for (i = 1; i <= lx; i++)
  for (j = 1; j <= ly; j++)
   if (x[i - 1] == y[j - 1])
    ts[i][j] = ts[i - 1][j - 1] + 1;
   else ts[i][j] = MAXF(ts[i][j - 1], ts[i - 1][j]);
 return ts[lx][ly];
}

int main()
{
 while (cin >> x >> y)
 {
#if 0
  printf("%s %s\n", x.c_str(), y.c_str());
#endif
  init();
  printf("%d\n", dp());
 }

 return 0;
}
 

 

 
搞掂{=      =+}