HDU 1003 Max Sum 最大接续子序列的和

HDU 1003 Max Sum 最大连续子序列的和
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6 很浅显的一道题 求一段序列中的 最大连续子序列的和 并输出 这段序列的起点和终点 因为是DP所有放了很久。。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int q[100001];
int main()
{
    int m,n,i,j,s;
    int sum,max,a,b;
    int t;
    int start,end;
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        if(k!=1)
            cout<<endl;
        scanf("%d",&m);
        for(i=0;i<m;i++)
            scanf("%d",&q[i]);
        sum=q[0];
        max=q[0];
        a=0,b=0;  
        start=0;end=0;       //初始化
        for(i=1;i<m;i++)
        {
            if(sum<0)           //类似于贪心思想,,当总和小于0时,要的是连续序列 则前面一段不要 
            {
                a=i;
                b=i;
                sum=q[i];
            }
            else
            {
                sum=sum+q[i];
                b=i;
            }
            if(sum>max)          //每次都要更新最大和值
            {
                max=sum;
                start=a;
                end=b;
            }
        }
        cout<<"Case "<<k<<':'<<endl;
        cout<<max<<' '<<start+1<<' '<<end+1<<endl;
    }
    return 0;
}