hdu 1217(Floyed) Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6522    Accepted Submission(s): 3019


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 
Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 
Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 
Sample Output
Case 1: Yes Case 2: No
 
题意:n种货币,有m种汇率,问某种货币能否通过汇率交易之后变得更多?
题解:假设某种货币最初是1,然后寻找某条回路,看最后它能不能变得比1更大,用Floyed就可以更新出所有的结果.
import java.util.HashMap;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = 1;
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0) break;
            double [][] map = new double [n][n];
            HashMap<String,Integer> hm = new HashMap<String,Integer>();
            for(int i=0;i<n;i++){
                String str = sc.next();
                hm.put(str,i);
            }
            int m = sc.nextInt();
            while(m-->0){
                String str1 = sc.next();
                double v = sc.nextDouble();
                String str2 = sc.next();
                int a = hm.get(str1);
                int b = hm.get(str2);
                map[a][b]= v;
            }
            for(int k=0;k<n;k++){
                for(int i=0;i<n;i++){
                    for(int j=0;j<n;j++){
                        if(map[i][j]<map[i][k]*map[k][j]) map[i][j] = map[i][k]*map[k][j];
                    }
                }
            }
            boolean flag = false;
            for(int i=0;i<n;i++) if(map[i][i]>1){flag=true;break;}
            System.out.print("Case "+(t++)+": ");
            if(flag) System.out.println("Yes");
            else System.out.println("No");
        }
    }
}