HDU 1081 To the Max 最大子矩阵(动态规划求最大连续子序列和)

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4  1
-1 8  0 -2

Sample Output

15

该题和之前做过的求最大连续子序列和有着共通之处,不同的地方是本问题求的是一个最大连续子矩阵,维度上变成了二维,那么我们能不能考虑压缩二维空间变为一维空间呢?

其实这是可以的。可以先选中矩阵的几行,逐列相加变为一个一维数组。(如果是一行的情况,则直接使用序列的最大连续段和方法)
多行变为一行时:例如
 0 -2 -7  0
 9  2 -6  2
-4  1 -4  1
-1  8  0 -2
当i=0, j=2时,则选择0,1,2行,逐列相加压缩为一行a,再从a中寻找最长连续子序列和
    0 -2 -7   0
    9  2 -6   2
   -4  1 -4   1
a: 5  1 -17 3
该问题中i和j需要遍历所有的情况,压缩所有情况为一个一维数组!!!

import java.util.*;
public class test {
  public static void main(String[] args) {
    int[][] a = new int[100][100];
    int[] b = new int[100];
    int n;
    Scanner in = new Scanner(System.in);
    n = in.nextInt();
    for (int i = 0; i < n; i++) {
      for (int j = 0; j < n; j++) {
        a[i][j] = in.nextInt();
      }
    }
    int ans = 0;
    for (int i = 0; i < n; i++) {
      for (int j = i; j < n; j++) {
        for (int k = 0; k < n; k++) {
          b[k] = 0;
          for (int l = i; l <= j; l++) {
            b[k] += a[l][k];//合并i到j行
          }
        }
        // 动态规划
        int sum = 0;//当前和
        int max = 0;//最大和
        //dp[i] = max(dp[i], dp[i - 1] + a[i]);
        for (int k = 0; k < n; k++) {
          sum += b[k];// 含有第k个元素的最大连续子段和
          if (sum > max) {
            max = sum;
          }
          if (sum < 0) {
            sum = 0;
          }
        }
        if (max > ans) {//更新ans
          ans = max;
        }
      }
    }
    System.out.println(ans);
  }
}