2015 HUAS Summer Trainning #5~N

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
2015 HUAS Summer Trainning #5~N

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1
 

Sample Output

14
解题思路:这个背包问题的特点是:每种物品只有一件,可以选择放或者不放,但只能选一种情况。可以设置一个数组记录状态。
程序代码:
#include<stdio.h>
#include<string.h>
const int maxn=10010;
int a[maxn],b[maxn],f[maxn];
int main()
{
 int t,n,v,i,j;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d%d",&n,&v);
  memset(f,0,sizeof(f));
  for(i=1;i<=n;i++)
   scanf("%d",&a[i]);
  for(i=1;i<=n;i++)
   scanf("%d",&b[i]);
  for(i=1;i<=n;i++)
            for(j=v;j>=b[i];j--)
                if(f[j]<f[j-b[i]]+a[i])
                    f[j]=f[j-b[i]]+a[i];
        printf("%d ",f[v]);
    }
    return 0;
}