The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple

Doki Doki Literature Club

Time Limit: 1 Second      Memory Limit: 65536 KB

Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!

A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple

The poem writing mini-game (from wikipedia)

BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of  strings, and the happiness of Sayori after reading the poem is calculated by the formula

 

where  is the happiness and  is Sayori's preference to the word .

Given a list of  words to maximize the happiness of Sayori.

Please note that each word can be used at most once!

Input

There are multiple test cases. The first line of input contains an integer  (about 100), indicating the number of test cases. For each test case:

The first line contains two integers ), indicating the number of words and the length of the poem.

For the following .

Output

For each test case output one line containing an integer  separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the lexicographically smallest one.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

sequence of .

string .

Sample Input

4
10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200
5 5
collegiate 0
programming -5
zhejiang 10
provincial 5
contest -45
3 2
bcda 1
bcd 1
bbbbb 1
3 2
a 1
aa 1
aaa 1

Sample Output

2018 if winter comes can spring be far behind
15 zhejiang provincial collegiate programming contest
3 bbbbb bcd
3 a aa

原题地址:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5761
题意:
给N个单词,让你从中选出M个单词选出组成一个句子使得这个句子通过指定的算式计算获得的值最大,并输出最终的句子,如果值相同输出字典序最小的句子

思路:The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple
仔细看上面算式发现这个算式需要值大的在前面才能满足最大值并且字典序最小也提醒我们需要用到排序

代码:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[5000000];
int b[5000000];
struct node{
        ll num;
        string str;
};
int cmp(node a,node b){ //按照要求排序
        if(a.num==b.num)return a.str<b.str;
        else return a.num>b.num;
}
int main()
{
    std::ios::sync_with_stdio(false);
    int t;
    cin>>t;

    while(t--){
        int n,m;
        cin>>n>>m;
        map<string,ll>mp;
        vector<node>ve;
        string ss;
        ll maxnum;                                      //注意这个longlong 这题就是因为这个精度wa了搞得我后面运用了去重又wa一次
        for(int i=1;i<=n;i++){
                cin>>ss>>maxnum;
                if(mp[ss]){
                        if(mp[ss]<maxnum){
                                mp[ss]=maxnum;
                        }
                }
                else{
                        mp[ss]=maxnum;
                }
        }
        map<string,ll>::iterator it; //去掉重复的单词,相同的单词保留值最大的单词
        for(it=mp.begin();it!=mp.end();it++){
                node now;
                now.str=it->first;
                now.num=it->second;
                ve.push_back(now);
        }
        sort(ve.begin(),ve.end(),cmp);
        ll sum=0;
        for(int i=1;i<=m;i++){
                ll cnt=ve[i-1].num;
                sum+=(m-i+1)*cnt;
        }
        cout<<sum<<" ";
        for(int i=0;i<m;i++){
                cout<<ve[i].str;
                if(i==m-1)cout<<endl;
                else cout<<" ";
        }
    }
    return 0;
}