poj 1458 Common Subsequence(dp)

poj 1458 Common Subsequence(dp)

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 46630   Accepted: 19154

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Java AC 代码:

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        
        Scanner sc = new Scanner(System.in);
        String first = "";
        String second = "";
        while(!(first = sc.next()).equals("") && !(second = sc.next()).equals("")) {
            char[] firstArray = first.toCharArray();
            char[] secondArray = second.toCharArray();
            int firstLen = first.length();
            int secondLen = second.length();
            int[][] subMaxLen = new int[firstLen + 1][secondLen + 1];  //这里设置成长度加1的,是为了防止下面 i-1 j-1的时候数组越界。
            for(int i = 1; i <= firstLen; i++)
                for(int j = 1; j <= secondLen; j++) {
                    if(firstArray[i - 1] == secondArray[j - 1]) 
                        subMaxLen[i][j] = subMaxLen[i - 1][j - 1] + 1;
                    else
                        subMaxLen[i][j] = (subMaxLen[i - 1][j] > subMaxLen[i][j - 1] ? subMaxLen[i - 1][j] : subMaxLen[i][j - 1]);
                }
            System.out.println(subMaxLen[firstLen][secondLen]);
        }

    }

}