hdoj1002--A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
 
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
 
简单题:大数的运算

注意格式(Case的首字母大写、各种空格、每一行之间有空行,最后一行没有空行)!

给出几组测试数据:

6
1 2
1 0
9999 1
1 999999
5555 4445
112233445566778899 998877665544332211
 
java code:
import java.util.*;
import java.io.*;
import java.math.*;

class Main
{
    public static BigInteger plus(BigInteger a, BigInteger b) {
        BigInteger c;
        c = a.add(b);
        return c;
    }
    
    public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        int T, i;
        BigInteger a,b;
        T = cin.nextInt();
        i = 1;
        while((T--) > 0) {
            a = cin.nextBigInteger();
            b = cin.nextBigInteger();
            System.out.println("Case "+ i +":");
            System.out.println(a + " + "+ b + " = "+ plus(a, b));
            i++;
            if(T > 0)
                System.out.println();
        }
    }
}

C code

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
void solve() { int n,i,j,k,flag,t,cas,L; char a[1001],b[1001],c[1002]; scanf("%d",&n); getchar(); cas=1; while(n--) { flag=0; memset(a,'