HDU1004 ZOJ2104 Let the Balloon Rise【MAP】

Let the Balloon Rise

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink



Author: WU, Jiazhi
Source: Zhejiang Provincial Programming Contest 2004


问题链接HDU1004 ZOJ2104 Let the Balloon Rise

问题简述参见上文。

问题分析这个问题就是统计单词的数量问题,用map来实现最为合适。最后需要迭代器看一遍,找出出现次数最多的单词。

程序说明:map类型的变量balloon是局部变量,每次进入局部时都会被重新初始化,需要注意。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1004 ZOJ2104 Let the Balloon Rise */

#include <iostream>
#include <map>

using namespace std;

int main()
{
    int n;
    string s;

    while(cin >> n && n) {
        map<string, int> balloon;

        while(n--) {
            cin >> s;
            balloon[s]++;
        }

        int imax = 0;
        for(map<string, int>::iterator iter=balloon.begin(); iter!=balloon.end(); iter++)
            if(iter->second > imax) {
                imax = iter->second;
                s = iter->first;
            }

        cout << s << endl;
    }

    return 0;
}